Return to list

Aide pour assemblage d'un site lutece

avatar provided by gravatar.com brochardl | Apr 13, 2017 10:13:48 AM

Aide pour assemblage d'un site lutece

Bonjour, J’essaie de réaliser l'assemblage d'un site lutece. Je rencontre plusieurs problèmes : 1 - Construction from scratch : En essayant de créer un pom.xml d'après la documentation ici : https://fr.flossmanuals.net/lutece-guide-integrateur/comment-fonctionne-lassemblage/, les plugins sont mal compilés. En effet, de nombreux plugin sont ajouté comme suit : https://pastebin.com/7sVg2Bg1 Il faut ajouter le type : lutece-plugin. De nombreux pom.xml d'exemple sont sans ce paramètre et ne ce compile pas entièrement. Est-ce volontaire ? 2- Construction du Site éditorial riche J'ai essayé de construire le war avec le pom.xml que l'on peut trouver ici : http://fr.lutece.paris.fr/fr/jsp/site/Portal.jsp?page=appstore Il semble y avoir des problème de dépendance que je n'arrive pas à saisir : https://pastebin.com/H04a3u8p Comment doit-on compiler via ce pom.xml ? 3 - Installation du Site éditorial riche depuis le war prebuildé. Il semble y avoir une erreur car je n'arrive pas à me connecter avec le user admin. Il semble qu'un poste en parle déjà. Je voulais donc savoir si le correctif n'avait été fait ou pas ? Merci.

Vote Score 1

Share

Report

Commentaires (4 )

Posted by : brochardl | 10/05/2017 14:21:39
Merci pour vos retours. Cordialement, Ludovic.
 
Posted by : tdu | 05/05/2017 12:56:27
Bonjour, Dans l'ordre : 1 - Il manquait en effet une balise -type- sur chaque dépendances de plugins dans les exmeples de ce chapitre du manuel d'intégrateur. Elles ont été rajoutées. 2 - Comme vous l'avez indiqué dans votre dernière message le problème de dépendance se situe bien au niveau du plugin jcaptcha. Celui-ci n'est plus maintenu. Le plugin captcha et le module captcha jcatcha sont à utiliser à la place. En consé quence le pom de ce site a été modifié dans l'appstore. 3 - Un post traite bien de cette question - Version 4.0 : site-edito-riche - . La solution passait par une modification du fichier sql. Celle-ci a été faite dans l'appstore. Bien cordialement,
 
Posted by : brochardl | 13/04/2017 17:05:11
Le problème pour la compilation doit venir de jcaptcha qui n'est pas compatible avec les versions supérieure à 5.0.0-SNAPSHOT. fr.paris.lutece.plugins:plugin-jcaptcha:jar:2.1.4 - fr.paris.lutece:lutece-core:jar:[2.4.0,5.0.0-SNAPSHOT), Est-ce normal ?
 
Posted by : brochardl | 13/04/2017 10:15:59
Désolé pour le contenu mais l'éditeur wysiwyg semble HS.
 

 Top of the page

Return to list