Return to list

ERROR lutece.jpa - getEM( )

avatar provided by gravatar.com teamnet_hfo | Feb 12, 2015 2:12:25 PM

ERROR lutece.jpa - getEM( )

Bonjour,

L'erreur suivante est récurrente sur le site que je développe:
12/02/15 13:46:48 ERROR [http-bio-8080-exec-8] lutece.jpa - getEM( ) : no EntityManager found. Will use native entity manager factory [Transaction will not be supported]

Voici le paramétrage de connexion à la base de données, db.properties:
portal.poolservice=fr.paris.lutece.util.pool.service.TomcatConnectionService
portal.ds=jdbc/test

Et dans le fichier Xml sur tomcat:
Resource auth=''Container'' 
		driverClassName=''com.mysql.jdbc.Driver'' 
		initialSize=''20'' 
		logAbandoned=''true'' 
		maxActive=''100''
		name=''jdbc/test''
		username=''***''
		password=''***''
		removeAbandoned=''true''
		removeAbandonedTimeout=''300''
		validationQuery=''SELECT 1''
		validationInterval=''30000''
		type=''javax.sql.DataSource''
		url=''jdbc:mysql://localhost/test?autoReconnectForPools=true''

Auriez vous une piste pour corriger cette erreur ?
Cette erreur peut-elle provoquer des ralentissements sur le site ?

Merci d'avance

Vote Score -131

Share

Report

Commentaires (3 )

Posted by : jonenst | 31/08/2016 19:49:02
Bonjour, cette erreur peut survenir lorsqu'on a oublié d'utiliser l'annotation @Transactional dans la classe Home.
 
Posted by : teamnet_hfo | 18/02/2015 10:53:29
petit UP... Cette erreur apparait toujours.
 

avatar provided by gravatar.com jon | 25/02/2015 10:36:50

Bonjour, pouvez-vous partager un pom.xml permettant de reproduire le problème ?

 Top of the page

Return to list