Return to list

Report a problem about this suggest

Compatibilité des versions entre core et plugin/module

Bonjour,

Je suis débutant avec Lutèce. Je voudrais créer une webapp avec la version 4.1.0 du core de Lutèce.
L application au final fonctionne.
Cependant j ai une erreur au démarrage du projet assez inquiétante.
java.lang.IllegalStateException: Conflicting persistence unit definitions for name  jpaLuteceUnit .

J utilise la version 1.0.3 du module-jpa-hibernate(j ai essayé la version 1.0.4 et 1.0.5 et j ai aussi essayé de virer la dépendance en incluant seulement Hibernate en pensant que peut être dans la dernière version il y en aurait plus besoin).

J ai également voulu utiliser le plugin "plugin-newsletter" en version 3.0.0, le plugin est installé et activé.
Par contre ,lorsque j accède à la page d’administration des newsletter, j ai cette erreur:
				fr.paris.lutece.portal.service.util.AppException: Database access error for component  newsletter . Please check plugin installation and db.properties.

Pourtant les tables newsletter sont bien crées avec leurs données et les confs bdd sont correctes. Au niveau du configuration du plugin rien n est marqué dans la doc, donc je suppose qu il n y a rien a ajouter.

Est-ce que j utilise la bonne version?

Plus globalement, existe-t-il une matrice de correspondance pour les versions à utilisé avec le cœur de Lutèce ? Et s il n y a pas, quel moyen puis-je utilisé pour savoir quel version des plugins/modules je dois utiliser avec la version du core de lutèce?

merci, d avance.
ps: avant de poser cette question j ai regardé un peu sur tout le site pour trouver des réponses, sans succès.

16

Return to list