Return to list

Problème de création de la BDD de la démo avec Ant

avatar provided by gravatar.com Kaptain | Jan 19, 2010 2:16:53 PM

Problème de création de la BDD de la démo avec Ant

Bonjour,

Dans le cadre d'un projet, je suis amené à tester Lutece pour voir si ça colle bien aux besoins.

Pour ce faire j'ai pris le tuto d'installation de la version démo ici sur le wiki

Et je rencontre différents problèmes:
- Lors du déploiement du .war, celui ci est anormalement long, et se termine par une erreur SQL (je n'ai pas retenue le message d'erreur pensant le résoudre en mettant en place toute la bdd suivant l'étape suivante dans l'install)
- Lors de l'utilisation de la ANT dans le bon répertoire, les scripts se déroule bien, jusqu'à celui intitulé db_document_init

Par aileur j'ai également vu qu'on pouvais construire son architecture perso à l'aide de Maven, en décrivant simplement celle ci dans un pom.xml.

Est il possible de récupérer le pom.xml du site de démo?

Merci d'avance de l'aide que vous me fournirai dans mon avancement plutôt chaotique jusque là.

Vote Score 9

Share

Report

Commentaires (14 )

Posted by : TLA | 24/03/2010 11:34:24
Bonjour, après moult investigations, je m'apercois que ca marche parfaitement bien avec Ant 1.7.1 et plus avec Ant 1.8.0 ... Il te faut donc installer Ant 1.7.x t.
 
Posted by : TLA | 23/03/2010 17:04:51
Bonjour, en effet, j'obtiens la meme erreur. Un processus Java (Ant surement prend toute la cpu) alors que les scripts du plugin-document fonctionne correctement en dehors de la tache Ant ... je regarde t.
 
Posted by : vitalie.schiopu | 22/03/2010 22:55:15
Bonjour, J'ai essayé plusieurs fois lancer ANT pour generer la DB et les tables mais le souci persiste. Toujours un blocage sur db_document_init. Merci. Vitalie
 
Posted by : TLA | 22/03/2010 11:59:01
je viens de tout retester, tout fonctionne mis à part une petite erreur décrite et corrigé ici : http://dev.lutece.paris.fr/jira/browse/HTML-4 t.
 
Posted by : TLA | 22/03/2010 11:25:09
Bonjour, le pom.xml mélange des versions en SNAPSHOT avec des versions stables et des plages de versions (notamment pour le core). Je viens de remettre à jour la page du wiki qui propose un fichier pom.xml avec tous les plugins. http://dev.lutece.paris.fr/wikilutece/index.php?title=R%C3%A9alisation_d%27un_site#Fichier_pom.xml Peux tu recommencer et me dire si tu as les meme erreurs ? je vais m'installer la derniere version de Ant de mon coté pour tester. t.
 
Posted by : vitalie.schiopu | 22/03/2010 10:07:04
Bonjour, Pour ma configuration j'utilise: Java 1.6.0_18 MySQl 5.1.44 Maven 2.2.1 Ant 1.8.0 Tomcat 6.0.26 Voici le fichier pom.xml que j'ai passé à maven. [code] lutece-parent-pom fr.paris.lutece 2.17 4.0.0 fr.paris.lutece lutece_complete_test lutece-site 0.5-SNAPSHOT Premier site d'apprentissage luteceSnapshot luteceSnapshot http://dev.lutece.paris.fr/snapshot_repository true lutece luteceRepository http://dev.lutece.paris.fr/maven_repository false fr.paris.lutece lutece-core [2.3.2,2.4.0] lutece-core fr.paris.lutece.plugins module-formengine-etatcivil 2.0.14 lutece-plugin fr.paris.lutece.plugins module-mylutece-database 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-adminquery 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-childpages 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-codewizard 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-contact 2.1.1 lutece-plugin fr.paris.lutece.plugins plugin-dbpage 2.1.1 lutece-plugin fr.paris.lutece.plugins plugin-digglike 2.1.1 lutece-plugin fr.paris.lutece.plugins plugin-directory 1.2.1 lutece-plugin fr.paris.lutece.plugins plugin-document 2.1.1 lutece-plugin fr.paris.lutece.plugins plugin-folderlisting 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-form 2.3.1 lutece-plugin fr.paris.lutece.plugins plugin-formengine 2.1.2 lutece-plugin fr.paris.lutece.plugins plugin-googleapi 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-helpdesk 2.1.2 lutece-plugin fr.paris.lutece.plugins plugin-html 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-htmlpage 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-insertalbum 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-insertmap 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-jcaptcha 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-jsr170 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-library 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-linkpages 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-myapps 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-mylutece 2.2.0 lutece-plugin fr.paris.lutece.plugins plugin-newsletter 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-pagelinkservice 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-parisalacarte 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-pluginwizard 1.0.1 lutece-plugin fr.paris.lutece.plugins plugin-quicklinks 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-rss 2.2.1 lutece-plugin fr.paris.lutece.plugins plugin-searchstats 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-sitemap 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-systeminfo 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-tagcloud 2.1.1 lutece-plugin fr.paris.lutece.plugins plugin-updater 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-urlrewriter 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-urlrewriteradmin 1.1.0 lutece-plugin fr.paris.lutece.plugins plugin-whatsnew 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-workflow 1.2.0 lutece-plugin fr.paris.lutece.plugins plugin-xmlpage 2.1.0 lutece-plugin fr.paris.lutece.plugins plugin-xpagelinkservice 2.1.0 lutece-plugin fr.paris.lutece.plugins module-calendar-document 1.0.0-SNAPSHOT lutece-plugin fr.paris.lutece.plugins plugin-advert 2.0.0-SNAPSHOT lutece-plugin fr.paris.lutece.plugins library-httpaccess 2.2.6 fr.paris.lutece.plugins library-indexer 2.0.8 fr.paris.lutece.plugins library-rss 1.0.0 fr.paris.lutece.plugins library-updater 1.0.0 [/code]
 
Posted by : TLA | 22/03/2010 09:32:03
Bonjour, Peux tu poster ton pom.xml pour que j'essaie de reproduire le problème ? Quelles versions de mysql et java utilises tu ? t.
 
Posted by : vitalie.schiopu | 21/03/2010 14:17:32
Bonjour, J’ai en effet le même problème. Dès que je lance ANT, le script reste bloqué sur l’exécution du db_init_document. En fait, il semble entrer dans une boucle infinie vue que le processus java.exe utilise 100% du CPU et j’ai attendu plus de 40 min et sans changements. Je n’ai pas pu contourner ce problème et j’ai donc lancé manuellement chaque fichier sql pour initialiser la BD.
 
Posted by : Kaptain | 19/01/2010 16:25:31
Il semble que ça marche bien. Merci pour ce support rapide. Je pense revenir rapidement vers vous quand j'aurais un peu trop bidouillé. Cependant reste un problème, celui du blocage du script de création de table avec ant: arrivé là il ne va pas plus loin (j'ai renommer le dossier du plugin pour le mettre en fin de liste, et le problème persiste) [code]==================================================================== [echo] db_document_init: [echo] [echo] [echo] "document" pool wasn't defined in db.properties file. [echo] All tables will be create in core pool portal. [echo] [echo] Translating SQL files to fit mysql requirements [sql] Executing resource: C:\LuteceEnvironnement\workspace\test\target\site -demo-2.3.3-SNAPSHOT\WEB-INF\sql\tmp_983638429 [/code]
 
Posted by : TLA | 19/01/2010 15:42:18
Le plugin-jcaptcha dépend de librairie gratuite mais pas totalement libre donc qu'un repository Maven ne peut distribuer ... Il te faut donc : - soit installer les 3 librairies concernés (stritonus bla bla) dans ton repository maven local avec les lignes de commandes fournies par le message d'erreur que tu m'as copier/coller - soit retirer la dépendance vers le plugin-jcaptcha dans ton pom.xml si tu es dans le cadre d'un test, je te conseil la deuxième solution, c'est la plus simple :)
 
Posted by : Kaptain | 19/01/2010 15:34:37
Je n'ai pas trouver de fichier de log. Mais voici les erreurs retournées: [code][INFO] ------------------------------------------------------------------------ [ERROR] BUILD ERROR [INFO] ------------------------------------------------------------------------ [INFO] Failed to resolve artifact. Missing: ---------- 1) tritonus:tritonus-share:jar:0.3.6 Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=tritonus -DartifactId=tritonus-share -D version=0.3.6 -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=tritonus -DartifactId=tritonus-share -Dve rsion=0.3.6 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id] Path to dependency: 1) fr.paris.lutece:site-demo:lutece-site:2.3.3-SNAPSHOT 2) fr.paris.lutece.plugins:plugin-jcaptcha:lutece-plugin:2.1.1-SNAPSHOT 3) tritonus:tritonus-share:jar:0.3.6 2) tritonus:tritonus-dsp:jar:0.3.6 Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=tritonus -DartifactId=tritonus-dsp -Dve rsion=0.3.6 -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=tritonus -DartifactId=tritonus-dsp -Dvers ion=0.3.6 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id] Path to dependency: 1) fr.paris.lutece:site-demo:lutece-site:2.3.3-SNAPSHOT 2) fr.paris.lutece.plugins:plugin-jcaptcha:lutece-plugin:2.1.1-SNAPSHOT 3) tritonus:tritonus-dsp:jar:0.3.6 ---------- 2 required artifacts are missing. for artifact: fr.paris.lutece:site-demo:lutece-site:2.3.3-SNAPSHOT from the specified remote repositories: luteceSnapshot (http://dev.lutece.paris.fr/snapshot_repository), central (http://repo1.maven.org/maven2), maven2-repository.dev.java.net (http://download.java.net/maven/2/), lutece (http://dev.lutece.paris.fr/maven_repository) [/code] En espérant que ça puisse servir.
 
Posted by : TLA | 19/01/2010 15:05:08
Je viens de remettre à jour le pom.xml sur : http://dev.lutece.paris.fr/wikilutece/index.php?title=R%C3%A9alisation_d%27un_site Peux tu réessayer ta commande et donner les log en cas d'erreur :
mvn clean lutece:site-assembly -U
t.
 
Posted by : Kaptain | 19/01/2010 14:45:34
Merci pour cette réponse rapide. C'est suite à la consultation de ses tuts que je me suis dit qu'il faudrait que je récupère le pom.xml de la version démo afin d'avoir une architecture complète. J'ai essayé d'utiliser le pom.xml du tuto intitulé : Réalisation d'un site Mais j'ai une erreur lors du build: [code]Failed to resolve artifact No version are present in the repository for the artifact [...] fr.paris.lutece.plugins:plugin-rss:lutece-plugins:null[/code] Ne sachant pas quels plugins je vais être amené à utiliser j'aimerai mettre en place une solution générale pour pouvoir faire le tri en suivant.
 
Posted by : TLA | 19/01/2010 14:26:19
Bonjour et bienvenue sur Lutece ! Voici les tutoriaux qui sont plus à jour : http://dev.lutece.paris.fr/wikilutece/index.php?title=Tutoriels Il y a des tuts "pas à pas" très détaillés. il y a aussi des exemples de pom.xml n'hésite pas à reposer des questions avec les log que tu donnes ton serveur. t.
 

 Top of the page

Return to list