Forum Lutèce

phil89
 3  1289
3

pourquoi trace de SNAPSHOT version prod ?

pourquoi trace de SNAPSHOT version prod ?

[project xmlns=http://maven.apache.org/POM/4.0.0
 xmlns:xsi=http://www.w3.org/2001/XMLSchema-instance
 xsi:schemaLocation=http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd]
 [parent]   
    [artifactId]lutece-parent-pom[/artifactId]   
    [groupId]fr.paris.lutece[/groupId]   
    [version]2.30[/version]   
[/parent]  
 [modelVersion]4.0.0[/modelVersion]
 [groupId]fr.paris.lutece[/groupId]
 [artifactId]jce[/artifactId]
 [packaging]lutece-site[/packaging]
 [version]0.0.1[/version]
 [name]JCE[/name]
 [description]Proto JCE[/description]
 [repositories]
  [repository]
   [id]lutece[/id]
   [name]luteceRepository[/name]
   http://dev.lutece.paris.fr/maven_repository
   [snapshots]
    [enabled]false[/enabled]
   [/snapshots]
  [/repository]
 [/repositories]
 [dependencies]
        [dependency]
            [groupId]fr.paris.lutece[/groupId]
            [artifactId]lutece-core[/artifactId]
			    [version]3.0.2[/version]
            [type]lutece-core[/type]
        [/dependency]
 
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-document[/artifactId]
   [version]2.2.3[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-html[/artifactId]
   [version]2.1.3[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-insertalbum[/artifactId]
   [version]1.1.5[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-links[/artifactId]
   [version]2.0.8[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-folderlisting[/artifactId]
   [version]2.1.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-linkpages[/artifactId]
   [version]2.2.0[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-childpages[/artifactId]
   [version]2.1.2[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-calendar[/artifactId]
   [version]3.0.3[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-library[/artifactId]
   [version]2.1.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
   [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-newsletter[/artifactId]
   [version]2.2.5[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-whatsnew[/artifactId]
   [version]2.1.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-rss[/artifactId]
   [version]2.2.6[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-contact[/artifactId]
   [version]2.1.3[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency] 
   [groupId]fr.paris.lutece.plugins[/groupId] 
   [artifactId]module-mylutece-database[/artifactId] 
     [version]2.3.4[/version] 
   [type]lutece-plugin[/type] 
  [/dependency] 
   [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-upload[/artifactId]
   [version]2.1.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-insertmap[/artifactId]
   [version]1.1.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-form[/artifactId]
   [version]2.5.0[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-wrapper[/artifactId]
   [version]1.0.1[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-digglike[/artifactId]
   [version]2.2.4[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]plugin-urlrewriter[/artifactId]
   [version]1.1.3[/version]
   [type]lutece-plugin[/type]
  [/dependency]
  [dependency]
   [groupId]fr.paris.lutece.plugins[/groupId]
   [artifactId]library-lucene[/artifactId]
   [version]1.0.5[/version]
   [type]lutece-plugin[/type]
  [/dependency]
 [/dependencies]
[/project]

phil89
la trace [INFO] ------------------------------------------------------------------------ [INFO] Building JCE 0.0.1 [INFO] ------------------------------------------------------------------------ [WARNING] The POM for fr.paris.lutece.plugins:library-rbac-api:jar:1.0.0-SNAPSHOT is missing, no dependency information available [WARNING] The POM for fr.paris.lutece.plugins:library-workgroup-api:jar:1.0.0-SNAPSHOT is missing, no dependency information available [WARNING] The POM for fr.paris.lutece.plugins:library-freemarker:jar:1.0.0-SNAPSHOT is missing, no dependency information available [WARNING] The POM for fr.paris.lutece.plugins:library-workflow-core:jar:1.0.0-SNAPSHOT is missing, no dependency information available

 

LLI
Bonjour, La version 2.2.3 du plugin-document nécessite une version du core supérieure à celle que vous avez défini sur le pom.xml de votre site (3.0.2). Il faudrait vérifier pour chaque plugin ajouté dans votre site la version minimale requise du core. LLI

 

phil89
Bonjour, j'ai mis 3.1.7 a la place et j'ai le meme soucis, idem que mon POST BUILD FAILURE J'utilise depuis toujours un mvn -e -X lutece:site-assembly -U Merci d'avance Philippe